Skip to main content

Comments

1 comment

  • Charles Myron

    Try google translate. Or contact developer. If your website is built on CMS platforms then the chances are the language settings have been changed by mistake. You have to find that option and set that back to default "English" or whatever your preference is.

    0

Please sign in to leave a comment.

Powered by Zendesk