Skip to main content

How can I fix my homepage display error? Home page icons do not display properly.

Comments

8 comments

  • Karapuz

    Hello, Deák,

    You should check that the font file with these icons is loaded correctly on the page. In some cases, it is fixed when you load the website through https instead of http or when using a correct domain name (by adding www for example).

    Kind regards,

    Karapuz

    https://www.ka-station.com

    0
  • bryanwilder

    This page is good. But your internet in not stable due to this icons are not properly load in your side. Moreover there might be SSL issue with you website. You may not properly redirect it form http to https.

    -1
  • Deák István

    Thanks for the comments so far. I don't really know where the mistake might be. It writes the hosting provider to ssl the webpage. "Redirect all pages to ssl" is entered. What can I do?

    0
  • Karapuz

    Hello, Deák,

    I have checked your website, the font loads from www. domain but the website url does not contain www. You can fix it by changing the domain for font urls or try to add these lines to .htaccess to fix the CORS error

    Header add Access-Control-Allow-Origin "*"
    Header add Access-Control-Allow-Methods: "GET,POST,OPTIONS,DELETE,PUT"

    it was copied from here: https://stackoverflow.com/questions/14467673/enable-cors-in-htaccess

    Kind regards,

    Karapuz

    https://www.ka-station.com

     

    0
  • Deák István

    Thank you Karapuz!
    1. Yes! I have also noticed that https://www.domen.com works but https://domen.com is not good. Where can I rewrite my domain name to be good?
    2. Where do I paste the change code? In the .htaccess file?

     

    0
  • Karapuz

    Hello, Deák,

    1. The domain is specified in config.php file. Make sure that it contains www there.

    2. I guess, in any place of the .htaccess.

    Kind regards

    Karapuz

    0
  • Wesley8596

    Hi, No there is not any update. But kindly check your website may be by mistake you have installed any plugin which creating this issue. Because recently our ironing mat site was facing such issue. When I checked it in details so by mistake we have installed a plugin which was creating issue and was disturbing the whole site layout.

     
    -1
  • Deák István

    htaccess file

    # SEO URL Settings
    RewriteEngine On
    # If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

    RewriteBase /
    RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
    RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
    RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
    RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

    #RewriteCond %{SERVER_PORT} 80
    #RewriteRule ^(.*)$ https://www.mydomain.hu/$1 [R,L]

    ##### HTTP to HTTPS redirection
    ## Since you have enabled HSTS the first redirection rule will instruct the browser to visit the HTTPS version of your
    ## site. This prevents unsafe redirections through HTTP.
    RewriteCond %{HTTPS} !=on [OR]
    RewriteCond %{HTTP:X-Forwarded-Proto} =http
    RewriteRule .* https://mydomain.hu%{REQUEST_URI} [L,R=301]


    ### Additional Settings that may need to be enabled for some servers

    ##### Redirect non-www to www -- BEGIN
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L]
    ##### Redirect non-www to www -- END

     

    this is how a developer solved the problem. I don't know what might be wrongly installed, but it's just a redirect and not a definitive solution unfortunately.

    1

Please sign in to leave a comment.

Powered by Zendesk