Skip to main content

How do I remove index.php?route= from all links of my website

Comments

7 comments

  • Karapuz

    Hello, Owais,

    Most likely you have some incorrect rules in .htaccess file that add the index.php to the route. Try to disable .htaccess temporarily and see if it helps.

    Kind regards,

    Karapuz

    https://www.ka-station.com

    0
  • owais

    Thanks for the reply but i have disabled the htaccess but the issue remains the same showing i/%5Eusindex.php/ in all url shop and pages.

    Thanks

    0
  • Karapuz

    Hello, Owais,

    My second guess that maybe it might be some SEO extension in your store. Do you have one? 

    Kind regards

    Karapuz

    0
  • owais

    I don't have seo extension .These are the extension i have in installer
     
    These are the modules i have

    0
  • Karapuz

    Hello, Owais,

    I have no guesses then. You can contact me at support@ka-station.com and submit ftp access to the server where I will be able to investigate the issue and find out what is happening. It will be free for you. The investigation may take up to 48 hours.

    Kind regards,

    Karapuz

    0
  • jazim jj

    I have the same problem on my website https://essentialsclothing.net/, Please check this and tell me the solution.

    -1
  • maxmarrie

    It's too simple you just follow the below points or visit this website:

    The first thing You'll need is to make an index.php file. Go to the configuration..htaccess files should be made.
    Turn on Apache's rewriting mode. The next step is to use the following command to activate the mod rewrite.

    -1

Please sign in to leave a comment.

Powered by Zendesk